summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2020-05-14 19:55:55 +0200
committerGiovanni Santini2020-05-14 19:55:55 +0200
commit666bbd2ecb0f46f491d17fc95a01bea5f0ecd9a2 (patch)
tree7d33a7ea77255343a7d937a22e9bfbbfdc41d28d /PKGBUILD
parentd1d9d3783e24cfd8360484da21e93538945b4910 (diff)
downloadaur-666bbd2ecb0f46f491d17fc95a01bea5f0ecd9a2.tar.gz
upgpkg: telegram-desktop-dev 2.1.6-1
- Version bump. - Updated submodules. - Improved PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 49 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a5332d8d651..dc86d4283b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-dev
-pkgver=2.1.2
+pkgver=2.1.6
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=('i686' 'x86_64')
@@ -22,39 +22,45 @@ conflicts=('telegram-desktop')
_commit="tag=v$pkgver"
#_commit="commit=COMMIT_SHA1"
+# All the sources are Git repositories and might be adjusted when a build issue arise.
+# These files might require modifications to be up-to-date.
+# In such situation, extra patches will be added.
+# All the submodules "source" definitions are generated them via:
+# git submodule foreach --quiet 'echo \"${name##*/}::git+`git remote get-url origin`\"' | sort
source=(
- # Git repositories; might be adjusted when a build issue arise.
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#$_commit"
-
- # All the submodules. I've generated them via:
- # git submodule foreach --quiet 'echo \"${name##*/}::git+`git remote get-url origin`\"' | sort
"Catch::git+https://github.com/philsquared/Catch"
- "GSL::git+https://github.com/Microsoft/GSL.git"
- "QR::git+https://github.com/nayuki/QR-Code-generator"
"cmake::git+https://github.com/desktop-app/cmake_helpers.git"
"codegen::git+https://github.com/desktop-app/codegen.git"
"expected::git+https://github.com/TartanLlama/expected"
+ "fcitx5-qt::git+https://github.com/fcitx/fcitx5-qt.git"
+ "fcitx-qt5::git+https://github.com/fcitx/fcitx-qt5.git"
+ "GSL::git+https://github.com/Microsoft/GSL.git"
+ "hime::git+https://github.com/hime-ime/hime.git"
"hunspell::git+https://github.com/hunspell/hunspell"
"lib_base::git+https://github.com/desktop-app/lib_base.git"
"lib_crl::git+https://github.com/desktop-app/lib_crl.git"
+ "libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git"
"lib_lottie::git+https://github.com/desktop-app/lib_lottie.git"
"lib_qr::git+https://github.com/desktop-app/lib_qr.git"
+ "libqtxdg::git+https://github.com/lxqt/libqtxdg.git"
"lib_rlottie::git+https://github.com/desktop-app/lib_rlottie.git"
"lib_rpl::git+https://github.com/desktop-app/lib_rpl.git"
"lib_spellcheck::git+https://github.com/desktop-app/lib_spellcheck"
"lib_storage::git+https://github.com/desktop-app/lib_storage.git"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
"lib_tl::git+https://github.com/desktop-app/lib_tl.git"
"lib_ui::git+https://github.com/desktop-app/lib_ui.git"
- "libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git"
- "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
+ "lxqt-qtplugin::git+https://github.com/lxqt/lxqt-qtplugin.git"
"lz4::git+https://github.com/lz4/lz4.git"
+ "materialdecoration::git+https://github.com/desktop-app/materialdecoration.git"
+ "nimf::git+https://github.com/hamonikr/nimf.git"
+ "QR::git+https://github.com/nayuki/QR-Code-generator"
+ "qt5ct::git+https://github.com/desktop-app/qt5ct.git"
+ "range-v3::git+https://github.com/ericniebler/range-v3.git"
"rlottie::git+https://github.com/desktop-app/rlottie.git"
"variant::git+https://github.com/mapbox/variant"
"xxHash::git+https://github.com/Cyan4973/xxHash.git"
-
- # These files might require modifications to be up-to-date. If that is the
- # case, they will be updated in place and untracked temporarily.
- # No patch for now...!
)
sha512sums=('SKIP'
'SKIP'
@@ -79,6 +85,15 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -87,17 +102,7 @@ prepare() {
# Same magic as above.
# git submodule foreach --quiet 'echo git config submodule.$name.url \"\$srcdir/${name##*/}\"' | sort
- git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
- git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
- git config submodule.Telegram/ThirdParty/QR.url "$srcdir/QR"
- git config submodule.Telegram/ThirdParty/expected.url "$srcdir/expected"
- git config submodule.Telegram/ThirdParty/hunspell.url "$srcdir/hunspell"
- git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
- git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
- git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
- git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
- git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
- git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
+ git config submodule.cmake.url "$srcdir/cmake"
git config submodule.Telegram/codegen.url "$srcdir/codegen"
git config submodule.Telegram/lib_base.url "$srcdir/lib_base"
git config submodule.Telegram/lib_crl.url "$srcdir/lib_crl"
@@ -109,7 +114,26 @@ prepare() {
git config submodule.Telegram/lib_storage.url "$srcdir/lib_storage"
git config submodule.Telegram/lib_tl.url "$srcdir/lib_tl"
git config submodule.Telegram/lib_ui.url "$srcdir/lib_ui"
- git config submodule.cmake.url "$srcdir/cmake"
+ git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
+ git config submodule.Telegram/ThirdParty/expected.url "$srcdir/expected"
+ git config submodule.Telegram/ThirdParty/fcitx5-qt.url "$srcdir/fcitx5-qt"
+ git config submodule.Telegram/ThirdParty/fcitx-qt5.url "$srcdir/fcitx-qt5"
+ git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
+ git config submodule.Telegram/ThirdParty/hime.url "$srcdir/hime"
+ git config submodule.Telegram/ThirdParty/hunspell.url "$srcdir/hunspell"
+ git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
+ git config submodule.Telegram/ThirdParty/libqtxdg.url "$srcdir/libqtxdg"
+ git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
+ git config submodule.Telegram/ThirdParty/lxqt-qtplugin.url "$srcdir/lxqt-qtplugin"
+ git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
+ git config submodule.Telegram/ThirdParty/materialdecoration.url "$srcdir/materialdecoration"
+ git config submodule.Telegram/ThirdParty/nimf.url "$srcdir/nimf"
+ git config submodule.Telegram/ThirdParty/QR.url "$srcdir/QR"
+ git config submodule.Telegram/ThirdParty/qt5ct.url "$srcdir/qt5ct"
+ git config submodule.Telegram/ThirdParty/range-v3.url "$srcdir/range-v3"
+ git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
+ git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
# Magic is over!
git submodule update