summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2020-02-12 01:00:42 +0100
committerGiovanni Santini2020-02-12 01:00:42 +0100
commitb076a2c8bd7374c6c37d86b74e9e86c69711fdd5 (patch)
tree708f257ea889dde77f0d6f469d12d0c010f4514a /PKGBUILD
parentad66427af016bbd3723639311057fb7411bf4cce (diff)
downloadaur-b076a2c8bd7374c6c37d86b74e9e86c69711fdd5.tar.gz
upgpkg: telegram-desktop-dev 1.9.12-1
- Version bump.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41d3b68ecac7..046cc3f21ca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,15 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-dev
-pkgver=1.9.9
+pkgver=1.9.12
pkgrel=1
pkgdesc='Official Telegram Desktop client - development release'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
-depends=('enchant' 'ffmpeg' 'hicolor-icon-theme' 'libappindicator-gtk3'
- 'lz4' 'minizip' 'openal' 'qt5-imageformats' 'xxhash')
+depends=('enchant' 'libdbusmenu-qt5' 'ffmpeg' 'hicolor-icon-theme'
+ 'libappindicator-gtk3' 'lz4' 'minizip' 'openal' 'qt5-imageformats'
+ 'xxhash')
makedepends=('cmake' 'git' 'python' 'range-v3')
optdepends=('ttf-opensans: default Open Sans font family')
@@ -34,7 +35,6 @@ source=(
"cmake::git+https://github.com/desktop-app/cmake_helpers.git"
"codegen::git+https://github.com/desktop-app/codegen.git"
"expected::git+https://github.com/TartanLlama/expected"
- "helpers::git+https://github.com/desktop-app/gyp_helpers.git"
"lib_base::git+https://github.com/desktop-app/lib_base.git"
"lib_crl::git+https://github.com/desktop-app/lib_crl.git"
"lib_lottie::git+https://github.com/desktop-app/lib_lottie.git"
@@ -45,6 +45,7 @@ source=(
"lib_storage::git+https://github.com/desktop-app/lib_storage.git"
"lib_tl::git+https://github.com/desktop-app/lib_tl.git"
"lib_ui::git+https://github.com/desktop-app/lib_ui.git"
+ "libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git"
"libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
"lz4::git+https://github.com/lz4/lz4.git"
"rlottie::git+https://github.com/desktop-app/rlottie.git"
@@ -89,13 +90,13 @@ prepare() {
git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
git config submodule.Telegram/ThirdParty/QR.url "$srcdir/QR"
git config submodule.Telegram/ThirdParty/expected.url "$srcdir/expected"
+ git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
git config submodule.Telegram/codegen.url "$srcdir/codegen"
- git config submodule.Telegram/gyp/helpers.url "$srcdir/helpers"
git config submodule.Telegram/lib_base.url "$srcdir/lib_base"
git config submodule.Telegram/lib_crl.url "$srcdir/lib_crl"
git config submodule.Telegram/lib_lottie.url "$srcdir/lib_lottie"
@@ -134,15 +135,18 @@ build() {
-Ddisable_autoupdate=1 \
-DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
-DCMAKE_BUILD_TYPE=Release \
- -DTDESKTOP_API_TEST=ON \
-DDESKTOP_APP_USE_GLIBC_WRAPS=OFF \
-DDESKTOP_APP_USE_PACKAGED=ON \
+ -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF \
+ -DDESKTOP_APP_USE_PACKAGED_GSL=OFF \
-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
+ -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF \
-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON \
+ -DDESKTOP_APP_SPECIAL_TARGET="" \
+ -DTDESKTOP_API_TEST=ON \
-DTDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME=ON \
-DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION=ON \
-DTDESKTOP_USE_PACKAGED_TGVOIP=OFF \
- -DDESKTOP_APP_SPECIAL_TARGET="" \
-DTDESKTOP_LAUNCHER_BASENAME="telegram-desktop"
make -C build
}