summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorudf2020-08-21 11:45:10 +0200
committerudf2020-08-21 11:45:10 +0200
commitb0ae0eb4cf1924dfdc42fd6aa9ebaebd9ab34ffb (patch)
tree7497f21521a5108a8e93a6748a265361f91e4769 /PKGBUILD
parent957a7bce0b0655239f721368cba16c390f0c3365 (diff)
downloadaur-b0ae0eb4cf1924dfdc42fd6aa9ebaebd9ab34ffb.tar.gz
Update to version 2.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13e9f8335565..5189d579089a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-udf-patched
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc='Telegram Desktop client with several personal patches'
arch=('x86_64')
@@ -18,15 +18,16 @@ url="https://desktop.telegram.org/"
license=('GPL3')
depends=(
'hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal'
- 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5'
+ 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'qt5-wayland' 'gtk3'
)
-makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl')
+makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'libwebrtc')
optdepends=('ttf-opensans: default Open Sans font family')
provides=('telegram-desktop')
conflicts=('telegram-desktop')
source=(
"https://github.com/telegramdesktop/tdesktop/releases/download/v${pkgver}/tdesktop-${pkgver}-full.tar.gz"
+ "set_webrtc_location.patch::https://github.com/desktop-app/cmake_helpers/commit/7dc5da757124cb2d644e289a37d8957823a7f6c9.patch"
# Custom patches
"always_delete_for_everyone.patch"
"always_clear_history_for_everyone.patch"
@@ -35,7 +36,8 @@ source=(
"force_gtk_integration.patch"
)
sha512sums=(
- '2aeca83be7bc385bd7537d56ecf66996facedd0af588e743fedbb08c3158fc76436d6cf3b1fb5dd7c8d37b4471f739872ca54ba300aa1d0e0202e87c005703fd'
+ '65fa7641ed9ba2fcd4181e3f6bbc036dcf2ddcb12eb10a15a601e0fce79c0f99741b55741bb3c18b9de5d3cdb07190761ea0f8fbe111563f784e0ad3faea2ede'
+ '5405ec01bd19350141588aad40eec63e47cd601d4945ed28ba2aaf077b398f4b746c3299e047bf0fb534f073ac1b9d4a515c5cc3eca9cdc754ccf87d2ce7176e'
# Custom patches
'e88fa96024efc6176c818d0a46684e0ee1fb3a7bdadb323ad3b29f736209c80b6c31b135cf84389e7e2bbd614e57b241e4437c94b6fd114e73cfc418bf130015'
'4a7e9de924bbf32fb4cd24ffa2764bcf49e0540bba649829b180da20a62810d4a21ebf11529d4eca22c9ceaa93b434ca3fbfd0b636795f8109ea4e1eddbff8f3'
@@ -45,8 +47,11 @@ sha512sums=(
)
prepare() {
- cd tdesktop-$pkgver-full
+ cd tdesktop-$pkgver-full/cmake
+ patch -Np1 -i ../../set_webrtc_location.patch
+ sed 's|set(webrtc_build_loc ${webrtc_loc}/out/$<CONFIG>/obj)|set(webrtc_build_loc /usr/lib)|' -i external/webrtc/CMakeLists.txt
+ cd ..
# custom patches
patch -Np1 -i "$srcdir/always_delete_for_everyone.patch"
patch -Np1 -i "$srcdir/always_clear_history_for_everyone.patch"
@@ -58,18 +63,22 @@ prepare() {
build() {
cd tdesktop-$pkgver-full
- cmake -B build -G Ninja . \
+ # Turns out we're allowed to use the official API key that telegram uses for their snap builds:
+ # https://github.com/telegramdesktop/tdesktop/blob/8fab9167beb2407c1153930ed03a4badd0c2b59f/snap/snapcraft.yaml#L87-L88
+ # Thanks @primeos!
+ cmake . \
+ -B build \
+ -G Ninja \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=Release \
- -DTDESKTOP_API_TEST=ON \
- -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
- -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF \
- -DDESKTOP_APP_USE_PACKAGED_GSL=OFF \
+ -DTDESKTOP_API_ID=611335 \
+ -DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c \
-DTDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME=ON \
+ -DTDESKTOP_LAUNCHER_BASENAME="telegramdesktop" \
-DTDESKTOP_USE_PACKAGED_TGVOIP=OFF \
-DDESKTOP_APP_SPECIAL_TARGET="" \
- -DTDESKTOP_LAUNCHER_BASENAME="telegramdesktop" \
- -DTDESKTOP_USE_GTK_FILE_DIALOG=ON
+ -DDESKTOP_APP_WEBRTC_LOCATION=/usr/include/libwebrtc
+ # -DTDESKTOP_USE_GTK_FILE_DIALOG=ON
ninja -C build
}