diff options
author | j.r | 2022-07-07 13:30:06 +0200 |
---|---|---|
committer | j.r | 2022-07-07 13:30:06 +0200 |
commit | 2aad7f6d3f29db80ad6d0e75cdc4cba052914308 (patch) | |
tree | 72cbd6f041b6691c721322efd72f55d266953fbb /PKGBUILD | |
parent | d26d05bdba4828ca51485fc33063455e145dd26b (diff) | |
download | aur-2aad7f6d3f29db80ad6d0e75cdc4cba052914308.tar.gz |
Use python standard way for building
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -2,12 +2,13 @@ _pkgname=tg pkgname=telegram-$_pkgname pkgver=0.19.0 -pkgrel=1 +pkgrel=2 pkgdesc="terminal telegram client that really works" arch=('any') url="https://github.com/paul-nameless/tg" license=('Unlicense') depends=('python-telegram=0.15.0' 'python3' 'python-setuptools') +makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry') optdepends=( 'libnotify: for notifications, you could also use other programs: see config' 'ffmpeg: to record voice msgs and upload videos correctly' @@ -23,11 +24,11 @@ md5sums=('8ce8894aa02552526f912954e33c2174') build() { cd "$srcdir/$_pkgname-$pkgver" - python3 setup.py build + python -m build --wheel --no-isolation } package() { cd "$srcdir/$_pkgname-$pkgver" - python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build + python -m installer --destdir="$pkgdir" dist/*.whl } |