summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorj.r2022-09-04 23:53:30 +0200
committerj.r2022-09-04 23:53:30 +0200
commit3841d53dd0d1903a2c4300c2978bf6840f5fbe46 (patch)
tree6719a306e341f40031ae947f72a3f6f4bce6c649 /PKGBUILD
parent7be2e2dd46464400b7d7c7582118ae8c99fbcbe8 (diff)
downloadaur-3841d53dd0d1903a2c4300c2978bf6840f5fbe46.tar.gz
Allow python-telegram 0.16.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3288f3b7311e..2ac6ef1136e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: j.r <j.r@jugendhacker.de>
_pkgname=telegram-tg
pkgname=$_pkgname-git
-pkgver=0.19.0.r2.49981d1
+pkgver=0.19.0.r3.2b0c0cf
pkgrel=1
pkgdesc="terminal telegram client that really works"
arch=(any)
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
-depends=('python-telegram=0.15.0' 'python3' 'python-setuptools')
+depends=('python-telegram>=0.15.0' 'python3' 'python-setuptools')
makedepends=('git')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
@@ -19,8 +19,10 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/paul-nameless/tg.git")
-md5sums=('SKIP')
+source=("$_pkgname::git+https://github.com/paul-nameless/tg.git"
+ "0001-Allow-newer-python-telegram.patch")
+md5sums=('SKIP'
+ 'd036364babd1f2cb63693c7df6b4946e')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -28,6 +30,12 @@ pkgver() {
printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/\(v\)\(.*\)/\2/')"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ patch -p1 -i "${srcdir}/0001-Allow-newer-python-telegram.patch"
+}
+
build() {
cd "$srcdir/$_pkgname"