summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorj.r2021-04-22 10:53:01 +0200
committerj.r2021-04-22 10:53:01 +0200
commit79f2ced85a7d7ac11c5f8d07bf352a2d215d4b96 (patch)
treee31b701ba2c799222aa13a05974d39360af9c476 /PKGBUILD
parentfd12b444e6c9edb386e5cfe26cfc622edc59beb8 (diff)
downloadaur-79f2ced85a7d7ac11c5f8d07bf352a2d215d4b96.tar.gz
telegram-tg(-git): bump to 0.11.0
patches for python-telegram version are not needed anymore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4b97705b136..f30384ee8d40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: j.r <j.r@jugendhacker.de>
_pkgname=telegram-tg
pkgname=$_pkgname-git
-pkgver=0.7.0.r8.c7b08b3
+pkgver=0.11.0.r1.bba72ef
pkgrel=1
pkgdesc="terminal telegram client that really works"
arch=(any)
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
-depends=('python-telegram' 'python3')
+depends=('python-telegram=0.14.0' 'python3')
makedepends=('git' 'python-setuptools')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
@@ -19,10 +19,8 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/paul-nameless/tg.git"
- "0001-Change-setup.py-to-accept-new-python-telegram-ver.patch")
-md5sums=('SKIP'
- '7b9a556ce7d2203fbee32442a96d73bc')
+source=("$_pkgname::git+https://github.com/paul-nameless/tg.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -30,12 +28,6 @@ pkgver() {
printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/\(v\)\(.*\)/\2/')"
}
-prepare() {
- cd "${srcdir}/${_pkgname}"
-
- patch -p1 -i ${srcdir}/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
-}
-
build() {
cd "$srcdir/$_pkgname"