summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorj.r2021-02-22 09:58:47 +0100
committerj.r2021-02-22 09:58:47 +0100
commitbcd37cee240ef89f5baa136ff223ce632f8cb135 (patch)
tree8b38f5de6f794ac88e4a4cfc5e0012f637016195 /PKGBUILD
parent085a8b0464776d86e2a12da424b05003896dbce0 (diff)
downloadaur-bcd37cee240ef89f5baa136ff223ce632f8cb135.tar.gz
telegram-tg-git: fix compatibility with new libtd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d2068e31a96..21464e070b3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: j.r <j.r@jugendhacker.de>
_pkgname=telegram-tg
pkgname=$_pkgname-git
-pkgver=v0.7.0.r3.06f7c5b
-pkgrel=3
+pkgver=v0.7.0.r7.1cd023a
+pkgrel=1
pkgdesc="terminal telegram client that really works"
arch=(any)
url="https://github.com/paul-nameless/tg"
@@ -17,9 +17,11 @@ optdepends=(
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+https://github.com/paul-nameless/tg.git"
- "0001-Change-setup.py-to-accept-new-python-telegram-ver.patch")
+ "0001-Change-setup.py-to-accept-new-python-telegram-ver.patch"
+ "0002-Fix-compatibility-with-new-libtd-version.patch")
md5sums=('SKIP'
- 'b5128de4dab3dbe7aaea695ac0a0b1a8')
+ '7b9a556ce7d2203fbee32442a96d73bc'
+ '13f56d00337b141c270906f0df49e872')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -34,6 +36,7 @@ prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 -i ${srcdir}/0001-Change-setup.py-to-accept-new-python-telegram-ver.patch
+ patch -p1 -i ${srcdir}/0002-Fix-compatibility-with-new-libtd-version.patch
}
build() {