summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey Andreyev2018-11-30 02:49:23 +0300
committerAlexey Andreyev2018-11-30 02:49:23 +0300
commit0a798bba2d9ce98f51fd40245f17588027afa620 (patch)
tree50584069e443be381c81a44046aa8bd61b182cd7 /PKGBUILD
downloadaur-0a798bba2d9ce98f51fd40245f17588027afa620.tar.gz
initial master branch version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a7cb633d5d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alexey Andreyev <aa13q@ya.ru>
+
+_gitname=telepathy-tank
+pkgname=telepathy-tank-git
+pkgver=r10.5312a42
+pkgrel=1
+pkgdesc="Matrix connection operator for the Telepathy framework. WIP git branch"
+arch=(i686 x86_64 armv7 aarch64)
+url="https://telepathy.freedesktop.org/"
+license=(GPL)
+depends=('telepathy-qt-git' 'qt5-matrixclient-git>=r1102.98c4168')
+makedepends=(cmake git)
+provides=(telepathy-tank)
+conflicts=(telepathy-tank telepathy-tank-git-wip)
+source=("git+https://github.com/TelepathyIM/$_gitname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../telepathy-tank \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib/telepathy \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_VERSION_MAJOR=5
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}