summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2015-11-05 23:18:48 +0100
committerMuflone2015-11-05 23:18:48 +0100
commit1477b3dee45ae1aa98f62b5c205fe389cbbd7eab (patch)
tree7ae6f132f98dcdbde9e62098d7c9ffd2004a17cb /PKGBUILD
downloadaur-1477b3dee45ae1aa98f62b5c205fe389cbbd7eab.tar.gz
New package temp-throttle 2.20-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c384746313d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Ryan Young <ry an. ry. young@gmail.com> (omit spaces)
+
+pkgname=temp-throttle
+pkgver=2.20
+pkgrel=1
+pkgdesc="A shell script for throttling system CPU frequency based on a desired maximum temperature."
+arch=('any')
+url="https://github.com/Sepero/temp-throttle"
+license=('GPL2')
+source=("${pkgname}-v${pkgver}.tar.gz"::"https://github.com/Sepero/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}@.service")
+sha256sums=('4ab30f204bdf407ebbfa5abdaa3b3d780e3bc674dca0bb08dbde650ccc015cf7'
+ '18ae3edd7b41508da279df6d67f1c5d86e1dbfe2daebbc42bbe39c26031b22e0')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 'temp_throttle.sh' "${pkgdir}/usr/bin/${pkgname}"
+ install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.md"
+ install -m 755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 -t "${pkgdir}/usr/lib/systemd/system" "${srcdir}/${pkgname}@.service"
+}
+