summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-10-28 09:31:56 -0600
committeryochananmarqos2019-10-28 09:31:56 -0600
commit600753dfef8adc1c220abeac61a93ab9e5ea4f6f (patch)
treedc376b05d65005d2121c3f7e26516834d6a96f59 /PKGBUILD
downloadaur-600753dfef8adc1c220abeac61a93ab9e5ea4f6f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f7a2790e8cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Contributor: Protesilaos Stavrou <info at protesilaos dot com>
+pkgname=tempus-themes-vim-git
+pkgver=r36.60c8b5e
+pkgrel=1
+pkgdesc="Tempus Themes for Vim"
+arch=('any')
+url="https://protesilaos.com/tempus-themes"
+license=('GPL3')
+depends=('vim')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitlab.com/protesilaos/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/vim/vimfiles/colors"
+ install -Dm644 colors/*.vim "$pkgdir/usr/share/vim/vimfiles/colors"
+}