summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarkpelz2021-07-07 19:51:00 +0800
committerDarkpelz2021-07-07 19:51:00 +0800
commit4023306c4a390256d3740c5f042f398c2120cddf (patch)
treebd14e283416dc6cc88f7a31d917751afd2091578 /PKGBUILD
downloadaur-4023306c4a390256d3740c5f042f398c2120cddf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5427e922f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Luke 'Darkpelz' Huckman <lukeh@outlook.my>
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Ong Yong Xin <ongyongxin2020+github AT gmail DOT com>
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=tenacity-git
+pkgver=r19.g8733f591a
+pkgrel=1
+pkgdesc="FLOSS Audacity Fork. No telemetry, crash reports and other shenanigans like that!"
+arch=(i686 x86_64)
+url="https://github.com/tenacityteam/tenacity"
+license=(GPL2 CCPL)
+groups=(pro-audio)
+depends=(alsa-lib libx11 gtk3 expat libid3tag libogg libsndfile
+ libvorbis lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr soundtouch)
+makedepends=(git cmake clang sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs
+ ffmpeg jack nasm conan)
+# can't find system lame portmidi
+optdepends=('ffmpeg: additional import/export capabilities')
+provides=(audacity)
+conflicts=(audacity)
+source=(
+ "git+https://github.com/tenacityteam/tenacity.git"
+ "tenacity.patch"
+)
+sha256sums=('SKIP' 'c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96')
+
+pkgver() {
+ cd tenacity
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -d'.' -f2-
+}
+
+prepare() {
+ cd tenacity
+ patch --forward --strip=1 --input="${srcdir}/tenacity.patch"
+ touch ${srcdir}/tenacity/README.txt # missing file in upstream
+}
+
+build() {
+ mkdir tenacity/build
+ cd tenacity/build
+ CC=clang cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DwxBUILD_TOOLKIT:STRING=gtk3 \
+ -Daudacity_use_wxwidgets=local \
+ audacity_use_ffmpeg:STRING=loaded \
+ ..
+ cmake --build .
+ make .
+}
+
+package() {
+ cd tenacity/build
+ make DESTDIR="${pkgdir}" install
+}