aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAzusa Nakano2022-12-02 15:52:28 +1100
committerAzusa Nakano2022-12-02 15:52:28 +1100
commit1333c064c8ef8e502b80ca09ec5fa8bbffd65916 (patch)
tree2cc4c7fac0061846b41ad55b9ca138489f6ed3a5 /PKGBUILD
parent3a6ce3947eb7453b7e780aa17f04039b2e018914 (diff)
downloadaur-1333c064c8ef8e502b80ca09ec5fa8bbffd65916.tar.gz
pkgupd: 2.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf8d5a230516..dec9f4ba0027 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,9 @@ pkgname=()
[ "$_build_no_opt" -eq 1 ] && pkgname+=(tensorflow-amd-git python-tensorflow-amd-git)
[ "$_build_opt" -eq 1 ] && pkgname+=(tensorflow-opt-amd-git python-tensorflow-opt-amd-git)
-pkgver=2.10.0
+pkgver=2.11.0
_srcname="tensorflow"
-_pkgver=2.10.0
-pkgver=2.10.0
+_pkgver=2.11.0
pkgrel=1
pkgdesc="Library for computation using data flow graphs for scalable machine learning (AMD upstream)"
url="https://www.tensorflow.org/"
@@ -30,7 +29,7 @@ makedepends=('bazel' 'python-numpy' 'rocm-hip-sdk' 'rccl' 'git' 'miopen' 'python
'python-setuptools' 'python-h5py' 'python-keras-applications' 'python-keras-preprocessing'
'cython' 'patchelf' 'python-requests')
optdepends=('tensorboard: Tensorflow visualization toolkit')
-source=("tensorflow::git+https://github.com/ROCmSoftwarePlatform/tensorflow-upstream.git#branch=r2.10-rocm-enhanced"
+source=("tensorflow::git+https://github.com/ROCmSoftwarePlatform/tensorflow-upstream.git#branch=r2.11-rocm-enhanced"
fix-c++17-compat.patch
fix-cusolver-version.patch
remove-log-spam.patch)
@@ -84,6 +83,9 @@ prepare() {
sed -i 's/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/stream_executor/rocm/rocm_blas.h
sed -i 's/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/core/util/gpu_solvers.h
sed -i 's/rocm\/include\/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/stream_executor/rocm/rocblas_wrapper.h
+ sed -i 's/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/compiler/xla/stream_executor/rocm/rocm_blas.cc
+ sed -i 's/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/compiler/xla/stream_executor/rocm/rocm_blas.h
+ sed -i 's/rocblas.h"/rocblas\/rocblas.h"/g' tensorflow/compiler/xla/stream_executor/rocm/rocblas_wrapper.h
patch -Np1 -i "${srcdir}/fix-cusolver-version.patch"
patch -Np1 -i "${srcdir}/remove-log-spam.patch"