aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Peschel2023-07-19 23:00:43 -0400
committerMark Peschel2023-07-19 23:00:43 -0400
commit1963e74e1e17cf25a4bb6b3f174127feec821203 (patch)
treeed0fdc2719da5c34d84a096be027166fe647d162 /PKGBUILD
parentd529c0ede8354b1c3751d9a324d3d6ffcd6db5da (diff)
downloadaur-1963e74e1e17cf25a4bb6b3f174127feec821203.tar.gz
Fix /opt/rocm/hip/bin/hipcc: No such file or directory.
Copy lubosz homework: https://github.com/lubosz/tensorflow-rocm/commit/c7d2a99
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 318d6e87c222..e87642349ba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Mark Peschel <mpeschel10@gmail.com>
+# Contributor: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
# Contributor: anakano <azusanakan0 at outlook dot com>
# Contributor: wuxxin <wuxxin@gmail.com>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
@@ -41,13 +42,15 @@ source=('tensorflow-upstream-rocm::git+https://github.com/ROCmSoftwarePlatform/t
https://github.com/bazelbuild/bazel/releases/download/5.4.0/bazel_nojdk-5.4.0-linux-x86_64
fix-c++17-compat.patch
fix-cstdint-tsllibio-cache.patch
- remove-log-spam.patch)
+ remove-log-spam.patch
+ rocm_configure.bzl.patch)
sha512sums=( SKIP
'45325ef3130aa95d48121d8c39bb4e683bdb5faa936ff29af953a2c359edb441a29e2dc0cae53ec6c08eee0432c0eeeaa7a40fbd063467b7f3c250d0f7f8ffed'
'e2adb747cd1fe3c90686831703618af3f8bc8197a96d9e1e90e66db38dbc4e7a94d88dac755b25e288002983a87fcffbfb0d7c2e356d979d4635301c3daf9281'
'f682368bb47b2b022a51aa77345dfa30f3b0d7911c56515d428b8326ee3751242f375f4e715a37bb723ef20a86916dad9871c3c81b1b58da85e1ca202bc4901e'
'78bffffdb6fa58dfcfae37b4458c198a644605b9e9136ceef079d4d5002fad6f2ae39dee15e77e35c198267574860554a69e98674882164fad4b63e9ab68fb05'
- 'fde73feeb2bbb814ba229c2b879e5e5944fd658e9810937753a25f2650f57c49f8a435924b47a1a54eb2852f9713b19a15d42b307593e26a74ad65aeee22c36a')
+ 'fde73feeb2bbb814ba229c2b879e5e5944fd658e9810937753a25f2650f57c49f8a435924b47a1a54eb2852f9713b19a15d42b307593e26a74ad65aeee22c36a'
+ '572615399558cfb59e3d4311864ca6349f2fd039ddce6f85d85f24d52858f6705df320891730fd4114e7ef81e53b67cc9e03bd871c47ee640693460fb0e490ea')
# consolidate common dependencies to prevent mishaps
_common_py_depends=(python-termcolor python-astor python-gast03 python-numpy python-protobuf
@@ -105,6 +108,8 @@ prepare() {
patch -Np1 -i "${srcdir}/fix-cstdint-tsllibio-cache.patch" -d tensorflow-upstream-rocm
# Patch tensorflow/core/common_runtime/gpu_fusion_pass.cc to fix "ROCm Fusion is enabled." log spam.
patch -Np1 -i "${srcdir}/remove-log-spam.patch" -d tensorflow-upstream-rocm
+ # hipcc has moved from /opt/rocm/hip/bin/ to /opt/rocm/bin/
+ patch -Np1 -i "${srcdir}/rocm_configure.bzl.patch" -d tensorflow-upstream-rocm
[ -d tensorflow-upstream-opt-rocm ] && rm -rf tensorflow-upstream-opt-rocm
# cp may not replace files if they already exist, even if contents are different.