aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Peschel2023-08-11 22:55:05 -0400
committerMark Peschel2023-08-11 22:55:05 -0400
commitbd8c9722528a8d12691ef2cb0fafdbdea46551ee (patch)
treea8b9291fe80658d73562bd099a45f11cda333542 /PKGBUILD
parente6dac4d7d87ef3ebccd661f0a2055aa6e11ff134 (diff)
downloadaur-bd8c9722528a8d12691ef2cb0fafdbdea46551ee.tar.gz
Bump commit hash; remove rocm_configure patch
Upstream updated path from /hip/bin/hipcc to /bin/hipcc, so rocm_configure patch is no longer necessary. https://github.com/ROCmSoftwarePlatform/tensorflow-upstream/commit/70b5e994f6782c28db6db8a30e807459f21d14a1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 163ffd8b8355..eaff1272a913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgbase=tensorflow-amd-git
pkgname=(tensorflow-amd-git python-tensorflow-amd-git)
pkgver=2.13
-_known_good_commit=e337a608791a9b9cd494d08b09e0c93e8883b283
+_known_good_commit=2d52de6d2c9428162cf810fd1dda7c36ab6bc126
# You can find the latest probably successful official build at:
# http://ml-ci.amd.com:21096/job/tensorflow/job/release-rocmfork-r213-rocm-enhanced/job/release-build-whl/lastSuccessfulBuild/
# Look for the revision for the "ROCmSoftwarePlatform/tensorflow-upstream" repository.
@@ -45,15 +45,13 @@ source=('tensorflow-upstream-rocm::git+https://github.com/ROCmSoftwarePlatform/t
https://github.com/bazelbuild/bazel/releases/download/5.4.0/bazel_nojdk-5.4.0-linux-x86_64
fix-c++17-compat.patch
fix-cstdint-tsllibio-cache.patch
- remove-log-spam.patch
- rocm_configure.bzl.patch)
+ remove-log-spam.patch)
sha512sums=( SKIP
'45325ef3130aa95d48121d8c39bb4e683bdb5faa936ff29af953a2c359edb441a29e2dc0cae53ec6c08eee0432c0eeeaa7a40fbd063467b7f3c250d0f7f8ffed'
'e2adb747cd1fe3c90686831703618af3f8bc8197a96d9e1e90e66db38dbc4e7a94d88dac755b25e288002983a87fcffbfb0d7c2e356d979d4635301c3daf9281'
'f682368bb47b2b022a51aa77345dfa30f3b0d7911c56515d428b8326ee3751242f375f4e715a37bb723ef20a86916dad9871c3c81b1b58da85e1ca202bc4901e'
'78bffffdb6fa58dfcfae37b4458c198a644605b9e9136ceef079d4d5002fad6f2ae39dee15e77e35c198267574860554a69e98674882164fad4b63e9ab68fb05'
- 'fde73feeb2bbb814ba229c2b879e5e5944fd658e9810937753a25f2650f57c49f8a435924b47a1a54eb2852f9713b19a15d42b307593e26a74ad65aeee22c36a'
- 'bd87ebdc033b1da558d3b4826964731308bc738454162972d7e46a9f6e4494b4311eade8a18738f7a086fe7760f5f3f791842b3529ca484fdca328f7f787bb3d')
+ 'fde73feeb2bbb814ba229c2b879e5e5944fd658e9810937753a25f2650f57c49f8a435924b47a1a54eb2852f9713b19a15d42b307593e26a74ad65aeee22c36a')
# consolidate common dependencies to prevent mishaps
_common_py_depends=(python-termcolor python-astor python-gast03 python-numpy python-protobuf
@@ -113,8 +111,6 @@ prepare() {
patch -Np1 -i "${srcdir}/fix-cstdint-tsllibio-cache.patch" -d tensorflow-upstream-rocm
# Patch tensorflow/core/common_runtime/gpu_fusion_pass.cc to fix "ROCm Fusion is enabled." log spam.
patch -Np1 -i "${srcdir}/remove-log-spam.patch" -d tensorflow-upstream-rocm
- # hipcc has moved from /opt/rocm/hip/bin/ to /opt/rocm/bin/
- patch -Np1 -i "${srcdir}/rocm_configure.bzl.patch" -d tensorflow-upstream-rocm
if [ ! -f "/opt/rocm/bin/target.lst" ]; then
echo WARNING: If you are building for GPUs not currently installed in your machine,