aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Peschel2023-10-07 23:44:13 -0400
committerMark Peschel2023-10-07 23:44:13 -0400
commitc789afb0ee77a72e0ce1a0de59a211dce5b3229d (patch)
tree5c33daf463687e60e400824e69861a0ed8cdbd45 /PKGBUILD
parent613a0f5052ddcf4a445663e219d970f802c73e9e (diff)
downloadaur-c789afb0ee77a72e0ce1a0de59a211dce5b3229d.tar.gz
Fix: failing build makes later builds fail
In a previous commit, I tried to fix an issue where, when the version number of the wheel produced changes, a part of the script that selects that wheel automatically can crash. My solution was to delete those files if they exist. I got it wrong, though, and if the previous build fails, the directory containing the wheel will be created but empty and then the rm line will fail. This patch hopefully allows rm to ignore if the files do not exist.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69a527cc03a5..5b25ae8f81da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -94,7 +94,7 @@ prepare() {
# When upstream changes the name of the wheel, people who have built this package once will get a duplicate .whl file.
# This confuses `WHEEL_PACKAGE=$(find ...` and makes the python -m installer line fail.
# So clean tmprocm between builds.
- [ -d "$srcdir"/tmprocm ] && rm "$srcdir"/tmprocm/*
+ rm -f "$srcdir"/tmprocm/*
# Allow any bazel version
echo "*" > tensorflow-upstream-rocm/.bazelversion