aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Peschel2023-12-31 16:13:26 -0500
committerMark Peschel2023-12-31 16:13:26 -0500
commitd3f0084279b99ea3d945b0d1e5d1bb7c8456ee2b (patch)
tree792c12ce370408fe4a5442cbeb2ad9e6e5b01cb9 /PKGBUILD
parentb1a153058ab48af62560c06774b5b22d273ff878 (diff)
downloadaur-d3f0084279b99ea3d945b0d1e5d1bb7c8456ee2b.tar.gz
Bump commit hash
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a15f947ac080..e03cec6d9f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgbase=tensorflow-amd-git
pkgname=(tensorflow-amd-git python-tensorflow-amd-git)
pkgver=2.13
-_known_good_commit=644d3a917abbcc107fa61e4f719464b68efc2d5c
+_known_good_commit=92070027fdd41c14710a3bd21b5fca33d8408da0
# You can find the latest probably successful official build at:
# http://ml-ci.amd.com:21096/job/tensorflow/job/release-rocmfork-r213-rocm-enhanced/job/release-build-whl/lastSuccessfulBuild/
# Look for the revision for the "ROCmSoftwarePlatform/tensorflow-upstream" repository.
@@ -109,7 +109,7 @@ prepare() {
# setup.py generates ~1Mb of warnings if you don't explicitly include namespace packages.
sed -i -E "s/find_packages/find_namespace_packages/" tensorflow-upstream-rocm/tensorflow/tools/pip_package/setup.py
-
+
patch -Np1 -i "${srcdir}/fix-tensorflow-2.10-sparse-transpose-op2.patch" -d tensorflow-upstream-rocm
# Patch for gcc13: cstdint is no longer implicitly included in some headers, so include it explicitly.
# See https://gcc.gnu.org/gcc-13/porting_to.html
@@ -185,6 +185,16 @@ build() {
export TF_NEED_ROCM=1
./configure
+ # echo
+ # echo
+ # echo
+ # sed -i -E "s/\"-licuuc\"/\"--verbose\", \"-lkrunk\", \"-licuuc\"/" "${srcdir}"/tensorflow-upstream-rocm/third_party/icu/BUILD.system
+ # # sed -i -E -z "s/name = \"icuuc\",\n/name = \"icuuc\",\n copts = \[\"-licuuc\", \"--verbose\"\],\n/" "${srcdir}"/tensorflow-upstream-rocm/third_party/icu/BUILD.system
+
+ # echo
+ # echo
+ # echo
+
bazel \
build ${BAZEL_ARGS[@]} \
//tensorflow:libtensorflow.so \