summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Bruckner2017-05-08 21:10:54 +0200
committerMax Bruckner2017-05-08 21:10:54 +0200
commit8d77d9fe68c4e80241c78890a9868b51f8fb49f0 (patch)
tree624e16c37bb930c8db12cd5cdd8379926a41a359 /PKGBUILD
parentb3f0a8a9df318cf1005125a08a73caead22877b8 (diff)
downloadaur-8d77d9fe68c4e80241c78890a9868b51f8fb49f0.tar.gz
terasology-1:1.4.0alpha7-3: Update dependencies
Remove unused native libraries and add dependencies for xorg packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0f9e7ca6c8f..3c694a4aadb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@ pkgname=terasology
_version=1.4.0
_version_postfix=alpha7
pkgver=${_version}${_version_postfix}
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Yet another high resolution game with blocks like Minecraft!"
arch=('x86_64' 'i686')
license=('Apache')
url="http://terasology.org"
options=('!strip')
-depends=('java-environment-openjdk=8' 'openal')
+depends=('java-environment-openjdk=8' 'openal' 'libxcursor' 'libxxf86vm' 'libxrandr')
makedepends=('unzip')
source=(
"$pkgname"
@@ -44,6 +44,12 @@ package() {
#remove files/dirs for other operating systems
rm run_macosx.command Terasology.{x86,x64}.exe
rm -r natives/{macosx,windows}
+ rm natives/linux/libopenal*
+ if [[ "$CARCH" == 'x86_64' ]]; then
+ rm natives/linux/lib{jinput-linux,lwjgl}.so
+ elif [[ "$CARCH" == 'i686' ]]; then
+ rm natives/linux/lib{jinput-linux,lwjgl}64.so
+ fi
cp -ra "$srcdir" "${pkgdir}/usr/share/${pkgname}"
}