summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Kuc2018-05-25 18:24:49 +0100
committerMichael Kuc2018-05-25 18:24:49 +0100
commit089e37c3b49e8982f2084edbb9d4301e3e051181 (patch)
tree686d8ccbe9983e16bdc39d9ad09b92ac486c1d3b /PKGBUILD
downloadaur-089e37c3b49e8982f2084edbb9d4301e3e051181.tar.gz
Initial commit of .SRCINFO and PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33cc78f0e303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Michael Kuc <michaelkuc6 at gmail dot com>
+# Contributor: Ihor Kalnytskyi <ikalnytskyi at github dot com>
+
+pkgname=termcolor-git
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc='Termcolor is a header-only C++ library for printing colored messages to the terminal. Written just for fun with a help of the Force.'
+arch=('x86_64')
+url='https://github.com/ikalnytskyi/termcolor'
+license=('BSD')
+groups=()
+depends=()
+makedepends=('git' 'cmake')
+checkdepends=()
+optdepends=()
+provides=('termcolor')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/ikalnytskyi/termcolor.git")
+noextract=()
+validpgpkeys=()
+sha256sums=('SKIP')
+
+prepare() {
+ # cd "$pkgname
+ :
+}
+
+build() {
+ cd "${pkgname}"
+ cmake .
+ make
+}
+
+check() {
+ cd "${pkgname}"
+ ./test_termcolor
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm644 "include/termcolor/termcolor.hpp" "${pkgdir}/usr/include/termcolor/termcolor.hpp"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}