summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Kuehler2019-06-16 22:57:17 -0700
committerKevin Kuehler2019-06-16 22:57:17 -0700
commit0353e3892ce472215de5435e342fe444f427a39e (patch)
treee89cec1eb15d2f2c8e4062dc6c0e8acc4d0e904e /PKGBUILD
downloadaur-0353e3892ce472215de5435e342fe444f427a39e.tar.gz
Create termgraph-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a188b7164fe2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin Kuehler <keur@ocf.berkeley.edu>
+
+_pkgname=termgraph
+pkgname="$_pkgname-git"
+pkgver=0.2.0.r4.gc40b864
+pkgrel=1
+pkgdesc="A python command-line tool which draws basic graphs in the terminal."
+arch=('x86_64')
+url="https://github.com/mkaz/$_pkgname"
+license=('MIT')
+depends=('python')
+makedepends=('python')
+provides=('termgraph')
+conflicts=('termgraph')
+source=("$_pkgname::git+$url")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}