summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya2016-03-14 02:38:33 +0100
committerIsmaël Bouya2016-03-14 02:38:33 +0100
commitff8c1c853c1b200a481e8026898da2a5f0c450d7 (patch)
treee795c7ee66bee61b32f94014b085956978fd31ef /PKGBUILD
downloadaur-ff8c1c853c1b200a481e8026898da2a5f0c450d7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5c5965d41fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ismaël Bouya <ismael.bouya@normalesup.org>
+
+_pkgname=terminal_velocity
+pkgname=terminal_velocity-git
+pkgver=0.96.5667177
+pkgrel=1
+pkgdesc="A fast note-taking app for the UNIX terminal"
+arch=('any')
+url="https://github.com/seanh/terminal_velocity"
+license=('GPL')
+depends=("python2-urwid" "python2-chardet")
+makedepends=('git')
+source=(
+ 'git://github.com/seanh/terminal_velocity.git'
+)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}