summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Harvey2016-08-19 18:46:58 -0400
committerJames Harvey2016-08-19 18:46:58 -0400
commit26ff3a59526264cecf94084a662925bee5683aa8 (patch)
tree5b4e6a0470b7a51548e3f4d2a87ceb9e60048dc7 /PKGBUILD
parentd35265609e8131b5b34af5734288dfd85eb8623b (diff)
downloadaur-26ff3a59526264cecf94084a662925bee5683aa8.tar.gz
PKGBUILD is now patterned after community's terminator 0.98-2. (Hadn't realized this wasn't changed when terminator-bzr and terminator-trunk merged.) Only functional change is eliminating terminator.install, with pacman's new hooks feature, and the gtk-update-icon-cache hook taking care of the icon cache.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 34 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74555146304d..57956750d9a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,54 @@
+# $Id$
+# Original Community Repo
+# =======================
+# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: fancris3 <fancris3 at gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+# Modifications to Use Bzr Trunk Source
+# =====================================
# Maintainer: Quan Guo <guotsuan@gamil.com>, James Harvey <jamespharvey20@gmail.com>
-# Contributor: TDY <tdy@gmx.com>
-# Contributor: zhuqin <zhuqin83@gmail.com>
+# * This .PKGFILE as closely as possible matches community's terminator 0.98-2
pkgname=terminator-bzr
-pkgver=0.98.r1743
+_pkgname=terminator
+pkgver=0.98.r1754
pkgrel=1
-pkgdesc="A tool for arranging multiple terminals in a single window"
-arch=('i686' 'x86_64')
-url="http://www.tenshu.net/terminator/"
-license=('GPL')
-depends=('pygtk' 'python2-keybinder2' 'python2-notify'
- 'vte' 'xdg-utils' 'python2-psutil')
-makedepends=('bzr' 'desktop-file-utils' 'gettext' 'intltool')
-optdepends=('gnome-python: gnome-terminal profile support')
+pkgdesc='Terminal emulator that supports tabs and grids (bzr trunk developmental version)'
+arch=('any')
+url='http://gnometerminator.blogspot.fr/p/introduction.html'
+license=('GPL2')
+# Note: the package named 'vte3' is actually vte for GTK 3
+# and terminator seems to require vte for GTK 2
+depends=('vte' 'pygtk' 'dbus-glib' 'xdg-utils' 'python2-notify' 'python2-keybinder2' 'python2-psutil')
+makedepends=('desktop-file-utils' 'gettext' 'intltool' 'bzr')
provides=('terminator')
conflicts=('terminator')
-_pkgname=terminator
source=("${_pkgname}::bzr+https://code.launchpad.net/~gnome-terminator/terminator/trunk")
md5sums=('SKIP')
-install=terminator.install
-
-
pkgver() {
cd ${srcdir}/${_pkgname}
echo $(tail -n 1 terminatorlib/version.py | sed "s|^APP_VERSION = '||" | sed "s|'$||").r$(bzr revno "${srcdir}/${_pkgname}")
}
build() {
- rm -rf "$srcdir/${_pkgname}-build"
- cp -r "$srcdir/${_pkgname}" "$srcdir/${_pkgname}-build"
- cd "$srcdir/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
+
+ # python2 fix
+ for file in terminatorlib/{,plugins/}*.py; do
+ sed -i 's_#!/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
+ done
- msg "Starting make..."
- find -type f -name '*.py' -exec sed -i '1s,python,&2,' '{}' \;
- python2 setup.py build
+ python2 setup.py build
}
package() {
- cd "$srcdir/${_pkgname}-build"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
- rm -f "$pkgdir/usr/share/icons/hicolor/icon-theme.cache"
+ cd "${srcdir}/${_pkgname}"
+
+ python2 setup.py install --skip-build --root="${pkgdir}"
+
+ rm -f "${pkgdir}/usr/share/icons/hicolor/icon-theme.cache"
}