summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2016-07-19 17:12:37 -0400
committerJames An2016-07-19 17:12:37 -0400
commit868b07d402dd024b756cbda6271b7cd923a28b1f (patch)
treeb132274a7851350595a4b3a9a88f02d3f8a64e32 /PKGBUILD
downloadaur-868b07d402dd024b756cbda6271b7cd923a28b1f.tar.gz
Initial commit with working package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f993f7e5ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=terminus
+pkgver=0.11.2
+pkgrel=1
+pkgdesc="The Pantheon CLI — a standalone utility for performing operations on the Pantheon Platform https://pantheon.io"
+arch=('any')
+url="https://github.com/pantheon-systems/$pkgname"
+license=('MIT')
+depends=('php')
+makedepends=('git')
+checkdepends=('php-behat' 'phpunit')
+optdepends=('composer' 'drush' 'git')
+source=("https://github.com/pantheon-systems/$pkgname/releases/download/$pkgver/$pkgname.phar"
+ "https://raw.githubusercontent.com/pantheon-systems/$pkgname/$pkgver/LICENSE.txt"
+ "https://raw.githubusercontent.com/pantheon-systems/$pkgname/$pkgver/utils/$pkgname-completion.bash")
+md5sums=('3d502ca3bf6c24fc4164f8c0a17523c6'
+ '727fd1133932956555ff7dbbf03f8d19'
+ 'ee0ac20ffb763afccf64234c96575b8c')
+
+pkgver() {
+ curl "https://api.github.com/repos/pantheon-systems/$pkgname/releases/latest" | grep tag_name | cut -f4 -d\"
+}
+
+check() {
+ cd "$_pkgname"
+
+ php -d phar.readonly=Off /usr/bin/php-box verify $_pkgname.phar
+}
+
+package() {
+ install -Dm755 "$pkgname.phar" "$pkgdir/usr/share/webapps/$pkgname/$pkgname.phar"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/license/$pkgname/LICENSE"
+ install -Dm644 "$pkgname-completion.bash" "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+
+ install --directory "$pkgdir/usr/bin"
+ ln --symbolic "/usr/share/webapps/$pkgname/$pkgname.phar" "$pkgdir/usr/bin/$pkgname"
+}