summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2018-05-27 20:38:23 -0400
committerSolomon Choina2018-05-27 20:38:23 -0400
commitbaf2a5e80900ed194e2ff69ffde38280b1f0b140 (patch)
tree18025d577564521aec6dcf9a74b1e8698313ff89 /PKGBUILD
parenta31fbfbd82dac6d3c5d98e03473dd0b36f0db2fc (diff)
downloadaur-baf2a5e80900ed194e2ff69ffde38280b1f0b140.tar.gz
just use the bin for now the source build works weirdly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ca47d749a73..9cb1279652a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,14 @@ pkgname=terminus-terminal
_pkgname=terminus
_pkgver=1.0.0
pkgver=v1.0.0.alpha.47.r0.g1d69082
-pkgrel=1
+pkgrel=2
alpha=47
pkgdesc="A terminal for a more modern age"
arch=('x86_64')
url="https://eugeny.github.io/terminus/"
license=('MIT')
depends=('nodejs' 'fontconfig')
-makedepends=('git' 'npm' 'yarn' 'python2' 'npm-check-updates')
-provides=("terminus-terminal")
-conflicts=("terminus-terminal")
-replaces=('terminus-terminal')
+makedepends=('git' 'npm' 'yarn' 'python2')
source=("git+https://github.com/Eugeny/terminus#tag=v${_pkgver}-alpha.${alpha}")
sha256sums=('SKIP')
@@ -27,11 +24,6 @@ build(){
cd "$srcdir/$_pkgname/"
yarn install
./scripts/install-deps.js
- cd terminus-terminal/node_modules/font-manager
- ncu -uan
- npm install
- cd $srcdir/$_pkgname
- ./scripts/install-deps.js
yarn run build
./scripts/build-native.js
./scripts/build-linux.js