summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Nixon2015-06-23 16:43:20 +0100
committerChris Nixon2015-06-23 16:57:34 +0100
commit4a218723cd3a917e4c70a0e99e308e4ff75445ca (patch)
tree1e23730f27f8d581f92e4f9ee3b81172e83e737d /PKGBUILD
downloadaur-4a218723cd3a917e4c70a0e99e308e4ff75445ca.tar.gz
Initial Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58118c3dba70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Chris Nixon <chris.nixon@sigma.me.uk>
+pkgname="tesseract-ocr-git"
+pkgver=3.04.rc1.r66.g941d870
+pkgrel=1
+pkgdesc="OCR Engine developed at HP Labs and now sponsored by Google."
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/tesseract-ocr/"
+license=('Apache')
+groups=()
+depends=('gcc-libs' 'libtiff' 'libpng' 'leptonica' 'giflib' 'libjpeg')
+optdepends=('cairo' 'icu' 'pango')
+source=('tesseract-ocr::git+https://code.google.com/p/tesseract-ocr')
+makedepends=('git' 'pango' 'icu' 'cairo')
+provides=('tesseract')
+conflicts=('tesseract')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd tesseract-ocr
+ echo $(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+}
+
+build() {
+ cd tesseract-ocr
+ git checkout $(git describe --tags `git rev-list --tags --max-count=1`)
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make clean
+ make
+}
+
+package() {
+ cd tesseract-ocr
+ make DESTDIR="$pkgdir/" install
+}