summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEdgar Rios2023-10-31 12:01:58 +0100
committerEdgar Rios2023-10-31 12:08:42 +0100
commitbf1cd4bcf56c3faaddd799cf84e343eef61c75b5 (patch)
tree400ff5bbb6f2d0fc77a3d6162fc597deac7cb3b4 /PKGBUILD
parent88b7f01e37b15c781360b3407610fd141c891a47 (diff)
downloadaur-bf1cd4bcf56c3faaddd799cf84e343eef61c75b5.tar.gz
Add instructions to download sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d1399fe8917..aa5427cffdd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
# Contributor: Dylon Edwards <deltaecho at archlinux dot us>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: haawda
+# Maintainer: eDgar <edgar `not@` openmail cc>
pkgname=tetgen
pkgver=1.6.0
@@ -11,11 +13,17 @@ license=('AGPL3')
# You must accept the licensing terms before downloading the source archive:
# http://wias-berlin.de/software/tetgen/download2.jsp
# Place the downloaded archive in $SRCDEST of your /etc/makepkg.conf
-source=("http://wias-berlin.de/software/tetgen/1.6/src/${pkgname}${pkgver}.tar.gz")
+source=("${pkgname}${pkgver}.tar.gz")
sha256sums=('87b5e61ebd3a471fc4f2cdd7124c2b11dd6639f4feb1f941a5d2f5110d05ce39')
options=('staticlibs')
makedepends=('cmake')
+[ ! -f ${pkgname}${pkgver}.tar.gz ] &&
+ printf "1. Visit http://wias-berlin.de/software/tetgen/download2.jsp\n" &&
+ printf "2. Place the downloaded tar.gz in \$SRCDEST (/etc/makepkg.conf;\n" &&
+ printf " right now SRCDEST=$SRCDEST)\n" &&
+ printf "3. When ready, try again.\n" && exit
+
build() {
[[ -d build ]] && rm -rf build
mkdir build