summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-08-17 20:57:27 +0200
committerXZS2016-08-17 20:57:27 +0200
commit8d888dd8158cfc4bdc758288d81139b9ada2fafc (patch)
tree537ee666e568134c4c78fb51eb86becb867cdb75 /PKGBUILD
parent36f9381adb04be7d2e0925e3b5608d51baf791a0 (diff)
downloadaur-8d888dd8158cfc4bdc758288d81139b9ada2fafc.tar.gz
support arbitrary integrity checks
The git-makepkg-templates switched to dynamic adaptation to integrity checks chosen in makepkg.conf. [1] The default checksums chosen reflect recommendations from the Arch Linux Wiki and manual pages. [2] [1]: https://github.com/dffischer/git-makepkg-templates/commit/e84d04b [2]: https://aur.archlinux.org/cgit/aur.git/commit/?h=git-makepkg-templates-git&id=c2ccaaa
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2195df925af..28e8ee6b5575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,11 @@ install='tllocalmgr.install'
_giturl="git://projects.archlinux.org/users/remy/${pkgname%-git}.git"
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-md5sums+=('SKIP')
+for integ in $(get_integlist)
+do
+ typeset -n array="${integ}sums"
+ array+=('SKIP')
+done
provides+=("$_gitname=$pkgver")
conflicts+=("$_gitname")
pkgver() {