summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2023-01-29 17:13:15 +0100
committerhaawda2023-01-29 17:13:15 +0100
commitcbd41fb6b6946a6a92cd3c80a190a178518982ed (patch)
tree1b1cc8450ec6329b399d13b773413df6162a8233 /PKGBUILD
parentcc7da281e092fa0a59feda4b5371387bc3b5da76 (diff)
downloadaur-cbd41fb6b6946a6a92cd3c80a190a178518982ed.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b19c1002605..af43174eb674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=texmacs-svn
_pkgname=texmacs
-pkgver=20221102.14062
+pkgver=20230129.14108
pkgrel=1
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor and CAS-interface."
arch=('x86_64')
@@ -14,7 +14,6 @@ url="http://www.texmacs.org/"
license=('GPL3')
depends=('perl' 'guile1.8' 'texlive-core' 'python' 'libxext' 'freetype2'
'qt5-svg' 'hicolor-icon-theme' 'gawk')
-
optdepends=('transfig: convert images using fig2ps'
'ghostscript: rendering ps files'
'imagemagick: convert images'
@@ -25,10 +24,11 @@ sha256sums=('SKIP')
options=('!emptydirs' '!ccache')
provides=('texmacs')
conflicts=('texmacs')
+LANG=C
pkgver() {
cd ${_pkgname}
- LANG=C svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
}
prepare() {
@@ -50,12 +50,12 @@ build() {
package() {
cd ${_pkgname}/build
- make DESTDIR=${pkgdir} install
+ make DESTDIR="$pkgdir" install
# fix fig2ps script
- sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
+ sed -i 's|${prefix}|/usr|' "$pkgdir"/usr/bin/fig2ps
# fix FS#37518
- sed -i '/^Path=/d' "${pkgdir}/usr/share/applications/texmacs.desktop"
+ sed -i '/^Path=/d' "$pkgdir"/usr/share/applications/texmacs.desktop
}
# vim:set ts=2 sw=2 et: