summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-11-02 20:26:40 +0100
committerHyacinthe Cartiaux2015-06-09 14:15:03 +0200
commit7584fa2c3255f6d05213c7ddd3831effd41117aa (patch)
tree226cfbb1297e2939416db6a72090d99214d6c3c1 /PKGBUILD
downloadaur-7584fa2c3255f6d05213c7ddd3831effd41117aa.tar.gz
[texmaker-qt4] Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baa4236d24d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Federico Cinelli <cinelli@aur.archlinux.org>
+
+pkgname=texmaker-qt4
+pkgver=4.1
+pkgrel=2
+pkgdesc='Free cross-platform LaTeX editor'
+arch=('i686' 'x86_64')
+url="http://www.xm1math.net/texmaker/index.html"
+license=('GPL')
+depends=('poppler-qt4' 'qtwebkit' 'desktop-file-utils')
+optdepends=('ghostscript: LaTeX to HTML conversion command'
+ 'ibus-qt: accented characters support'
+ 'poppler: PDF rendering support')
+install="$pkgname.install"
+source=("http://www.xm1math.net/texmaker/texmaker-$pkgver.tar.bz2")
+md5sums=('97ef7f97e73d69283391e467e5758275')
+conflicts=('texmaker')
+provides=('texmaker')
+
+build() {
+ cd "texmaker-$pkgver"
+ qmake-qt4 PREFIX=/usr texmaker.pro
+ make
+}
+package() {
+ cd "$srcdir/texmaker-$pkgver"
+
+ install -dm755 "$pkgdir/usr/share"
+ make INSTALL_PATH="$pkgdir" INSTALL_ROOT="$pkgdir" PREFIX="/usr" install
+}
+