summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRay Shirohara2021-05-16 17:15:44 +0900
committerRay Shirohara2021-05-16 17:16:48 +0900
commit666e063c97b9be6d254151fa50b797841a1ee6ac (patch)
tree2838606dc980a25c40e5d74c23123e36fc70d6d9 /PKGBUILD
downloadaur-666e063c97b9be6d254151fa50b797841a1ee6ac.tar.gz
Initial import with version 3.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd6d1a5c991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ray Shirohara <RShirohara@gmail.com>
+
+pkgname=textimg
+pkgver=3.0.6
+pkgrel=1
+pkgdesc='Command to convert from color text (ANSI or 256) to image.'
+arch=('x86_64')
+url='https://github.com/jiro4989/textimg'
+license=('MIT')
+makedepends=('go')
+provides=('textimg')
+options=('!strip')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('ab7ad2965a826cc576ba23f3e75e0e973e0bfcd675a6183d674badb17ba6812c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ go test -cover ./...
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}