summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaFeLP2022-06-07 23:22:05 +0200
committerMaFeLP2022-06-07 23:22:05 +0200
commit7471cfc173d4022fef0d1cf3f42b55a7bb5a1c73 (patch)
treedb328bc99f3fc3446d2bb9d8b3614912825ac237 /PKGBUILD
downloadaur-textshine.tar.gz
Initial commit
Signed-off-by: MaFeLP <60669873+MaFeLP@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddde68a9987d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: MaFeLP <mafelp@proton.me>
+pkgname='textshine'
+pkgver='1.2.0'
+pkgrel='1'
+pkgdesc='Powerfully transform text'
+arch=('x86_64')
+url='https://github.com/phase1geo/TextShine'
+license=('GPL3')
+depends=(
+ 'glib2'
+ 'glibc'
+ 'libgee'
+ 'granite'
+ 'gtk3'
+ 'pango'
+ 'cairo'
+ 'libxml2'
+ 'gtksourceview4'
+ 'evolution-data-server'
+ 'libhandy'
+ 'gtkspell3'
+ 'discount'
+)
+makedepends=(
+ 'vala'
+ 'python-pip'
+ 'python-setuptools'
+ 'meson'
+)
+source=("TextShine.tar.gz"::"https://github.com/phase1geo/TextShine/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('908fd084cb9731458340205234ff24eda923e7c91fb4e00d233872643294ce9c')
+
+build() {
+ cd "TextShine-${pkgver}"
+ meson build --prefix=/usr
+}
+
+package() {
+ cd "TextShine-${pkgver}/build"
+ meson install --destdir="${pkgdir}"
+}
+