summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorshellkr2016-06-26 05:24:32 +0200
committershellkr2016-06-26 05:24:32 +0200
commitbe0cba9f08d0058c3779cfd219282f5e275c0c46 (patch)
treef94b5c44a95e8a24259c451ddbd80219fc2f5cff /PKGBUILD
parent9b0648c700f32b0fb10a95623467360a3267712b (diff)
downloadaur-be0cba9f08d0058c3779cfd219282f5e275c0c46.tar.gz
Upstream restructured file layout and also added a man page
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af6e5f3ed25c..df025fec6288 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=textsuggest-git
_gitname=${pkgname%-git*}
-pkgver=r23.1519640
-pkgrel=2
+pkgver=r35.ccbcbc9
+pkgrel=1
pkgdesc='Simple Linux utility to autocomplete words using rofi'
arch=('any')
url="https://github.com/bharadwaj-raju/TextSuggest"
license=('GPL3')
-depends=('python' 'rofi' 'xorg-setxkbmap' 'xdotool' 'xclip')
+depends=('python' 'rofi' 'xdotool' 'xclip')
makedepends=('git')
provides=("$_gitname")
source=("$_gitname::git+https://github.com/bharadwaj-raju/TextSuggest.git")
@@ -21,20 +21,18 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
- patch -uN "TextSuggest.py" "$startdir/textsuggest.patch"
+ patch -uN "TextSuggest.py" "$startdir/textsuggest.patch"
}
package() {
cd "$srcdir/$_gitname"
- install -d "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/EnglishOpenWordList/"
- install -d "$pkgdir/usr/bin/"
- install -D -m755 TextSuggest.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 EnglishOpenWordList/* "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/EnglishOpenWordList/"
- install -D -m644 Extra_Words.txt "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 languages.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 fonts.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
+ install -d "$pkgdir/usr/share/"
+ cp -rf textsuggest "$pkgdir/usr/share/"
+ install -D -m755 TextSuggest.py "$pkgdir/usr/bin/textsuggest"
+ install -D -m644 languages.py -t "$pkgdir/usr/lib/python3.5/site-packages/"
+ install -D -m644 fonts.py -t "$pkgdir/usr/lib/python3.5/site-packages/"
+ install -D -m644 textsuggest.1 -t "$pkgdir/usr/share/man/man1/"
install -D -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- ln -fs "/usr/lib/python3.5/site-packages/textsuggest/TextSuggest.py" "$pkgdir/usr/bin/textsuggest"
}