summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Ott2015-06-28 15:09:38 -0400
committerKevin Ott2015-06-28 15:09:38 -0400
commit86348e4e32af747493ccf581f9bfca34ecfac291 (patch)
tree91f844352bc669593ea4f335e38d35fa35fdac06 /PKGBUILD
downloadaur-86348e4e32af747493ccf581f9bfca34ecfac291.tar.gz
Move files in preperation for aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4657c5dd765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Etzos <supercodingmonkey @ gmail.com>
+# Contributer: Gordin <9ordin @t gmail dot com>
+
+pkgname=texturepacker
+pkgver=3.7.1
+pkgrel=1
+pkgdesc="Sprite sheet creator and image optimizer"
+arch=('x86_64')
+url="http://www.texturepacker.com"
+license=('custom:texturepacker')
+install='texturepacker.install'
+depends=('glib2' 'hicolor-icon-theme' 'desktop-file-utils' 'shared-mime-info')
+source=("http://www.codeandweb.com/download/texturepacker/${pkgver}/TexturePacker-${pkgver}-ubuntu64.deb")
+md5sums=('9f75c5786602dc3942fdce2e3fe7a763')
+
+build() {
+ ar -xv "TexturePacker-${pkgver}-ubuntu64.deb"
+ tar -xvf data.tar.xz
+}
+
+package() {
+ # Program
+ mv ${srcdir}/usr ${pkgdir}
+ # License
+ install -Dm644 "${pkgdir}/usr/share/texturepacker/documents/LicenseAgreement.html" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.html"
+}