summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Wright2023-09-18 19:51:27 +0100
committerJonathan Wright2023-09-18 19:51:27 +0100
commit8f3feb87ac7af4dc5e85ede8022dd4ceda07a8e0 (patch)
treeac3cd3ce7fe2d0b47601331c9b3fa2b00c4105ee /PKGBUILD
parent408cedc9f98e4ddd422a08529f8b3587570ba388 (diff)
downloadaur-8f3feb87ac7af4dc5e85ede8022dd4ceda07a8e0.tar.gz
Add LICENSE installation for tflint-bin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57a104167156..a1231bc97329 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkg=tflint
pkgname=${_pkg}-bin
pkgver=0.48.0
-pkgrel=1
+pkgrel=2
pkgdesc="A linter for Terraform code"
arch=('x86_64')
url="https://github.com/terraform-linters/${_pkg}"
@@ -12,10 +12,17 @@ depends=('glibc')
makedepends=('zip')
conflicts=("${_pkg}")
provides=("${_pkg}")
-source=("tflint_linux_amd64-${pkgver}.zip::${url}/releases/download/v${pkgver}/tflint_linux_amd64.zip")
-sha512sums=('76e2446f94b28b3e1ac9b248ae25f6dd9db2280e00ffd32c51d114dfc308c8ee6ab43f61f56277d93e11314a8b8fe812632fe9f67de494dd43cad66ba9324905')
+source=(
+ "LICENSE"
+ "tflint_linux_amd64-${pkgver}.zip::${url}/releases/download/v${pkgver}/tflint_linux_amd64.zip"
+)
+sha512sums=(
+ 'SKIP'
+ '76e2446f94b28b3e1ac9b248ae25f6dd9db2280e00ffd32c51d114dfc308c8ee6ab43f61f56277d93e11314a8b8fe812632fe9f67de494dd43cad66ba9324905'
+)
package() {
- cd ${srcdir}
+ cd ${srcdir} || exit
install -Dm755 ${_pkg} ${pkgdir}/usr/bin/${_pkg}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
}