summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Wright2024-05-02 17:40:26 +0100
committerJonathan Wright2024-05-02 17:40:26 +0100
commite9cfc8f56e6da96e6e5f6f4814c141bdd66928a7 (patch)
tree6018c5a8def501c0b6011453521a4d6688a14926 /PKGBUILD
parentd6d129534c7a5b5c0de60f7374d7a0670ddba04e (diff)
downloadaur-e9cfc8f56e6da96e6e5f6f4814c141bdd66928a7.tar.gz
Update the licensing for tflint
Update the licensing for tflint as it now has a split license of MPL-2.0 for some components, and BUSL-1.1 for the embedded terraform binary.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eec55ea6169e..74488c0133b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
_pkg=tflint
pkgname=${_pkg}-bin
pkgver=0.51.0
-pkgrel=1
+pkgrel=2
pkgdesc="A linter for Terraform code"
arch=('x86_64')
url="https://github.com/terraform-linters/${_pkg}"
-license=('MIT')
+license=('MPL-2.0' 'BUSL-1.1')
depends=('glibc')
makedepends=('zip')
conflicts=("${_pkg}")
provides=("${_pkg}")
source=(
- "LICENSE"
+ "LICENSE-MPL-2.0"
+ "LICENSE-BUSL-1.1"
"tflint_linux_amd64-${pkgver}.zip::${url}/releases/download/v${pkgver}/tflint_linux_amd64.zip"
)
sha512sums=('c1e3a0c8f5267fb5c0b65733bda037c62d914ed989bee0f510d8196b1029eec00d40f415ce1514a4996d420ba02d856d04db0915b64573ef4a36033cc5efb94e'
+ 'de6495df79045a8e609771286ef2f3d0dd1908e4d8f61de5816b3e490114c76c49f0b5acf653541f283117a396f2d8e0dc5419f09e5d94aeac50c9a6d5f21fa2'
'c2088d335a3afddb1066a9f9e1520bb6d9dabf0ffebb717fcb55a18813ec0e2ff7bf36b9d351ca2a0e0e3e1b7ca72aedeed42d20c7c1fc2188baac2bb94d2661')
package() {
cd ${srcdir} || exit
install -Dm755 ${_pkg} ${pkgdir}/usr/bin/${_pkg}
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE-MPL-2.0 ${pkgdir}/usr/share/licenses/$pkgname/LICENSE-MPL-2.0
+ install -Dm644 LICENSE-BUSL-1.1 ${pkgdir}/usr/share/licenses/$pkgname/LICENSE-BUSL-1.1
}