summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchimede Pitagorico2017-12-02 00:13:46 +0800
committerArchimede Pitagorico2017-12-02 18:51:12 +0800
commit40f7793d64af3472113950eddf00948155541c7e (patch)
tree70798196f6b5e526abfa890177b482c95572b2a3 /PKGBUILD
downloadaur-40f7793d64af3472113950eddf00948155541c7e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a45cf93ab2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Archimede Pitagorico <archimede.pitagorico@mail.com>
+
+pkgname=tgcd
+pkgver=v1.1.1.0.g4222d3e
+pkgrel=1
+pkgdesc="tgcd, tcp gender change daemon (reverse tunnel)"
+arch=('x86_64')
+url='http://tgcd.sourceforge.net/#lbAD'
+license=('GNU-GPL2')
+source=('git+https://github.com/archimedepitagorico/tgcd.git#tag=v1.1.1'
+ )
+#install=$pkgname.install
+
+makedepends=('git'
+ )
+sha1sums=('SKIP'
+ )
+options=('!buildflags'
+ )
+
+pkgver() {
+ cd tgcd
+ echo "$(git describe --long --tags | tr - . | tr _ .)"
+}
+
+prepare() {
+ cd tgcd
+ ./configure
+}
+
+build() {
+ cd tgcd
+ make
+}
+
+package() {
+ cd tgcd
+ make DESTDIR=${pkgdir} install
+ mv ${pkgdir}/usr/local/* ${pkgdir}/usr
+ rmdir ${pkgdir}/usr/local
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}