summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHeorhi Valakhanovich2023-03-27 21:45:51 +0300
committerHeorhi Valakhanovich2023-03-27 21:45:51 +0300
commitfb68306dfa81dc87bf88572fc7c32106e4fa20ea (patch)
treeb601b64c3f09e7a4929c3454135feb63a37a7761 /PKGBUILD
downloadaur-fb68306dfa81dc87bf88572fc7c32106e4fa20ea.tar.gz
v2.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2152ab6ce65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: geov <code@mail.geov.name>
+
+pkgname=tgp
+pkgrel=1
+pkgver=0.2.1
+pkgdesc="tgp telegram proxy"
+arch=('x86_64' 'aarch64' 'i686')
+url="https://github.com/geovex/tgp"
+makedepends=('git' 'go')
+source=(
+ "https://github.com/geovex/tgp/archive/refs/tags/v${pkgver}.tar.gz"
+ tgp.service
+)
+sha256sums=('d7925af3354e348c9910fbe353fab76500f9a84eef981ce5bb55bfdbc881fa9b'
+ '61a78cb68d8e86ffbcb5e8a4328bd3581548531cc6fe5b02f6058176c97566b2')
+
+build() {
+ cd $pkgname-$pkgver
+ export GOFLAGS="-trimpath"
+ go build ./cmd/tgp
+}
+
+package() {
+ install -Dm755 "$pkgname-$pkgver/tgp" "$pkgdir/usr/bin/tgp"
+ install -Dm644 "tgp.service" "$pkgdir/usr/lib/systemd/system/tgp.service"
+}