summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCassandra Watergate2022-07-05 15:22:29 -0700
committerCassandra Watergate2022-07-05 15:22:29 -0700
commit2045e6885a5ca6884c154052cdc4b745fbdfa908 (patch)
tree30de64a2fd16bf0471c732fc9412cbc48ed315fa /PKGBUILD
parent7722a0ff13f4e680c2960e0d48201ea14b3edac3 (diff)
downloadaur-2045e6885a5ca6884c154052cdc4b745fbdfa908.tar.gz
fix with musl-libc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61466e2376fc..cf69bb770146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Cassandra Watergate (saltedcoffii) <cassandrawatergate@outlook.com>
pkgname=tgs-to-gif-cpp-git
-pkgver=0.1.2
-pkgrel=2
+pkgver=r6.f626548
+pkgrel=1
pkgdesc="Animated stickers for Telegram (*.tgs) to animated GIFs converter, c++ version"
arch=("x86_64" "i386" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/ed-asriyan/tgs-to-gif"
@@ -12,14 +12,19 @@ makedepends=('conan' 'cmake')
provides=('tgs-to-gif' 'tgs-to-gif-cpp' 'tgs-to-gif-git')
conflicts=('tgs-to-gif' 'tgs-to-gif-cpp' 'tgs-to-gif-git')
source=("git+https://github.com/ed-asriyan/tgs-to-gif"
- basename.patch)
+ basename.patch)
sha256sums=('SKIP'
- 'd5b6f6c734ed8dbc6ffed897e2789d3a6e2a93b5ff3cf85bf6d42298353d1e9f')
+ 'd5b6f6c734ed8dbc6ffed897e2789d3a6e2a93b5ff3cf85bf6d42298353d1e9f')
build() {
cd "tgs-to-gif"
git checkout master-cpp
- patch -Np1 -i ../basename.patch
+ # This patch fails when using musl libc, detect it and only apply the patch if not.
+ if [ -z $(ldd /bin/ls | grep 'musl' | head -1 | cut -d ' ' -f1) ]; then
+ patch -Np1 -i ../basename.patch
+ else
+ echo "Detected musl libc: not applying basename.patch"
+ fi
conan install . --build
cmake CMakeLists.txt
make