summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Van de Velde2023-05-18 22:15:57 +0200
committerBruno Van de Velde2023-05-18 22:15:57 +0200
commite4aa424dcf4ae33f2873963fbbf25c6125efd25d (patch)
tree23680b83c35878a8cde8a4fd9971bc1805ce8828 /PKGBUILD
parentb0ed1f21c0104a1810ddade2ce3eb3fad39c9371 (diff)
downloadaur-tgui-git.tar.gz
Icon and .desktop files no longer need to be manually installed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aee4dbe94546..0b68bd0f3abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bruno Van de Velde <bruno@texus.me>
pkgname=tgui-git
-pkgver=nightly_build.r41.g6f3cbdd6
+pkgver=nightly_build.r0.gddac6f47
pkgrel=1
pkgdesc="Cross-platform modern c++ GUI library"
arch=('i686' 'x86_64')
@@ -13,12 +13,8 @@ provides=('tgui')
conflicts=('tgui')
replaces=()
-source=("git+https://github.com/texus/TGUI.git#branch=1.x"
- tgui-gui-builder.desktop
- TexusGUI_48x48.png)
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("git+https://github.com/texus/TGUI.git#branch=1.x")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/TGUI"
@@ -50,6 +46,4 @@ package() {
cd "$srcdir/TGUI"
make DESTDIR="$pkgdir/" install
install -Dm644 ./license.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -Dm644 ../TexusGUI_48x48.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/TexusGUI.png"
- install -Dm644 ../tgui-gui-builder.desktop "${pkgdir}/usr/share/applications/tgui-gui-builder.desktop"
}