summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Van de Velde2021-11-01 15:50:29 +0100
committerBruno Van de Velde2021-11-01 15:50:29 +0100
commitd0a69f70413acb1172417bd7c2fe7c886adc801c (patch)
tree091abdf347d10ef2108b75f1bdfb8a038ce49af7 /PKGBUILD
parentb3fdf2aa28353b51f0b6b86ceaaba43fe44c5fdf (diff)
downloadaur-d0a69f70413acb1172417bd7c2fe7c886adc801c.tar.gz
Updated branch to 0.10 and build all backends instead of only SFML
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2dcdef4ceb0..faf89886362e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Bruno Van de Velde <bruno@texus.me>
pkgname=tgui-git
-pkgver=v0.9.1.r0.g588362edc
+pkgver=nightly_build.r0.g6ef550515
pkgrel=1
-pkgdesc="Cross-platform C++ GUI library for SFML"
+pkgdesc="Cross-platform modern c++ GUI library"
arch=('i686' 'x86_64')
url="https://tgui.eu/"
license=('ZLIB')
-depends=('sfml')
+depends=('sfml' 'sdl2' 'sdl2_ttf' 'glfw-x11' 'freetype2')
makedepends=('cmake' 'doxygen' 'git')
provides=('tgui')
conflicts=('tgui')
replaces=()
-source=("git+https://github.com/texus/TGUI.git#branch=0.9")
+source=("git+https://github.com/texus/TGUI.git#branch=0.10")
sha256sums=('SKIP')
pkgver() {
@@ -25,8 +25,20 @@ build() {
cd "$srcdir/TGUI"
cmake -DCMAKE_INSTALL_PREFIX=/usr . \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
- -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE \
- -DTGUI_BUILD_DOC=true
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON \
+ -DTGUI_CXX_STANDARD=17 \
+ -DTGUI_BUILD_DOC=ON \
+ -DTGUI_BUILD_GUI_BUILDER=ON \
+ -DTGUI_BACKEND=Custom \
+ -DTGUI_HAS_BACKEND_SFML_GRAPHICS=ON \
+ -DTGUI_HAS_BACKEND_SFML_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_RENDERER=ON \
+ -DTGUI_HAS_BACKEND_SDL_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_GLES2=ON \
+ -DTGUI_HAS_BACKEND_SDL_TTF_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_TTF_GLES2=ON \
+ -DTGUI_HAS_BACKEND_GLFW_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_GLFW_GLES2=ON
make
}