summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-02-21 20:21:43 +0100
committera8212024-02-21 20:21:43 +0100
commit5bb76b87f1452d53c731dee12dbe94050a7d03ce (patch)
tree1cdd0636160b8c0d8cf6fbc84563e59b5600611a /PKGBUILD
parentf06cc4122f8dbd4732903f272cf1f26923bd43a6 (diff)
downloadaur-the-deeps.tar.gz
Fix: remove sudo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a91f0b5c12c4..bd46a0377c3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,13 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Contributor: Evan Oicle <oicleevan@protonmail.com>
-# Maintainer: Evan Oicle <oicleevan@protonmail.com>
pkgname=the-deeps
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A text-based adventure game written in C++."
arch=('any')
url="https://github.com/oicleevan/the-deeps"
license=('MIT')
-source=("https://github.com/oicleevan/$pkgname/archive/refs/tags/$pkgver.zip")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oicleevan/$pkgname/archive/refs/tags/$pkgver.zip")
sha256sums=('d5a6fe6631f0dadc60fe06d3da6da54cb7792cdd69788b8166a65bb3cf2bc93a')
build() {
@@ -23,5 +19,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- sudo make install
+ install -Dm755 -t "$pkgdir/usr/bin" bin/$pkgname
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}