summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Wild2018-05-10 16:34:09 -0400
committerAllen Wild2018-05-10 16:34:09 -0400
commiteb648895de05118552dd50da339a19fda6236379 (patch)
tree6f68464bee09635715bef4fcfd355fa2cac1ffa5 /PKGBUILD
parentded112ae5356a68260b45d3a9b2c0cf4eafd766f (diff)
downloadaur-eb648895de05118552dd50da339a19fda6236379.tar.gz
Update to 2.1.0.r162.g889be25, add tests
Add python-cram as a check dependency, and explicitly disable the clang-format test since it doesn't matter for package building (and clang would be a pretty big dependency)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72daaf6d962b..931bb913ab51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgdesc="Allen Wild's fork of ag, which supports pcre2 and .agrc user config"
url='https://github.com/aswild/the_silver_searcher'
pkgname=the_silver_searcher_wild-git
-pkgver=2.1.0.r159.g9874910
+pkgver=2.1.0.r162.g889be25
pkgrel=1
provides=('the_silver_searcher')
conflicts=('the_silver_searcher')
@@ -14,6 +14,7 @@ license=('Apache')
depends=('pcre2' 'xz' 'zlib')
makedepends=('git')
+checkdepends=('python-cram')
_srcname="the_silver_searcher"
source=("git://github.com/aswild/${_srcname}.git")
@@ -27,10 +28,16 @@ pkgver() {
build() {
cd "$srcdir/$_srcname"
./autogen.sh
- ./configure --prefix=/usr --with-pcre2 --enable-zlib --enable-lzma
+ ./configure --prefix=/usr --with-pcre2 --enable-zlib --enable-lzma \
+ ac_cv_prog_CLANG_FORMAT=no
make
}
+check() {
+ cd "$srcdir/$_srcname"
+ make check
+}
+
package() {
cd "$srcdir/$_srcname"
make DESTDIR="$pkgdir/" install