summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Tran2016-02-17 21:59:02 +1100
committerVictor Tran2016-02-17 21:59:02 +1100
commite2c37b292e78c79ea207da37d9bed95c9bf286e9 (patch)
treeea5d08c3c76923f68c0e4bc0b237529462bdf5a6 /PKGBUILD
downloadaur-e2c37b292e78c79ea207da37d9bed95c9bf286e9.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..487f54cf93ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=thefile
+pkgver=1.0
+pkgrel=0
+pkgdesc="File Manager for theOS"
+arch=("x86_64")
+url="https://github.com/vicr123/thefile"
+license=('GPL2')
+depends=('kwidgetsaddons' 'xdg-utils')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/thefile#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/thefile" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/theFile.desktop" "$pkgdir/usr/share/applications"
+}