summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Tran2023-06-09 18:16:03 +1000
committerVictor Tran2023-06-09 18:16:57 +1000
commit71fd3fec41ae9a9ed8151f203f68c68455ce70f0 (patch)
treea67824af685556b478833b67072aaa894fe4e61c /PKGBUILD
parent6af8fc4bd48457023abb5a97f68daa6d302aee14 (diff)
downloadaur-71fd3fec41ae9a9ed8151f203f68c68455ce70f0.tar.gz
Update to 2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05f80d452664..281aaa472e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,33 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=('thefrisbee' 'libthefrisbee')
-pkgver=1.0
+pkgver=2.0
pkgrel=0
pkgdesc="Disk Management"
-arch=("x86_64")
-url="https://github.com/vicr123/thefrisbee"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/thefrisbee"
license=('GPL3')
-makedepends=('qt5-tools' 'the-libs')
-source=("$pkgname-$pkgver"::"https://github.com/vicr123/theFrisbee/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('a1b2dc15bcb2db0851ac7a79ba424e717ca890314c2b42027fbe3e4a9a71637e')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang' 'libcontemporary')
+source=("thefrisbee"::"https://github.com/theCheeseboard/theFrisbee/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('a596f17a414de78bbaf5ff6da1f4fa0773e21f4896c59a49c5b65e73c056adb9')
doInstallModule() {
- pushd "theFrisbee-$pkgver/build/$1"
- make install INSTALL_ROOT=$pkgdir
- popd
+ DESTDIR="$pkgdir" cmake --install "build/$1"
}
build() {
- cd "theFrisbee-$pkgver"
- mkdir -p build
- cd build
- qmake ../theFrisbee.pro
- make
+ cmake -B build -S "theFrisbee-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package_thefrisbee() {
- depends=('xdg-utils' 'qt5-base' 'the-libs' 'libthefrisbee')
+ depends=('xdg-utils' 'libcontemporary' 'libthefrisbee')
doInstallModule 'application'
}
package_libthefrisbee() {
- depends=('qt5-base' 'the-libs')
+ depends=('libcontemporary')
doInstallModule 'libthefrisbee'
}