summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-05-04 02:22:09 -0400
committeréclairevoyant2023-05-04 02:22:09 -0400
commit5209d5b1a2a00cdab6dab5ac3e8b0b8952f7b8c0 (patch)
treea05bd5cb58924600c4bd2452de15c1fff3481cd8 /PKGBUILD
parent61e55f5e8ea6ee403953c84e7ff910d2a439b372 (diff)
downloadaur-5209d5b1a2a00cdab6dab5ac3e8b0b8952f7b8c0.tar.gz
theharvester-git: follow PEP 517; remove broken test
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 34 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9e5740cf0a0..2def0469b881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Maintainer: éclairevoyant
pkgname=theharvester-git
-pkgver=4.2.0.r254.g5065d6c
+pkgver=4.2.0.r304.gd09392b
pkgrel=1
pkgdesc="Gather emails, names, subdomains, IPs and URLs related to targets using public sources"
-arch=('any')
+arch=(any)
url="https://github.com/laramies/theHarvester"
-license=('GPL2')
+license=(GPL2)
depends=(
- 'python-aiodns'
- 'python-aiofiles'
- 'python-aiohttp'
- 'python-aiomultiprocess'
- 'python-aiosqlite'
- 'python-argparse'
- 'python-beautifulsoup4'
- 'python-censys'
- 'python-certifi'
- 'python-dnspython'
- 'python-fastapi'
- 'python-lxml'
- 'python-netaddr'
- 'python-ujson'
- 'python-pyppeteer'
- 'python-yaml'
- 'python-requests'
- 'python-retrying'
- 'python-shodan'
- 'uvicorn'
- 'python-uvloop'
+ python-aiodns
+ python-aiofiles
+ python-aiohttp
+ python-aiomultiprocess
+ python-aiosqlite
+ python-beautifulsoup4
+ python-censys
+ python-certifi
+ python-dnspython
+ python-fastapi
+ python-lxml
+ python-netaddr
+ python-ujson
+ python-pyppeteer
+ python-yaml
+ python-requests
+ python-retrying
+ python-shodan
+ uvicorn
+ python-uvloop
)
-makedepends=('git' 'python-setuptools')
-checkdepends=('python-pytest')
+makedepends=(git python-{build,installer,wheel} python-setuptools)
+checkdepends=(python-pytest)
install="theHarvester.install"
source=("$pkgname::git+$url.git")
b2sums=('SKIP')
@@ -41,17 +40,23 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ # see laramies/theHarvester#1390
+ rm $pkgname/tests/discovery/test_qwantsearch.py
+}
+
build() {
cd $pkgname
- python setup.py build
+ python -m build -wn
}
check() {
cd $pkgname
- pytest
+ export PYTHONPATH="$PWD/build/lib"
+ python -m unittest discover
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}