aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorReto Brunner2024-05-12 13:22:10 +0200
committerReto Brunner2024-05-12 13:22:10 +0200
commit616413911d055a70e584aefc4aa95f4eae1c81a1 (patch)
tree2318ff0644dde9b9553e5d0c801d2adb981d4528 /PKGBUILD
parent935b1b1b70602410f6b58756bd1e65462107abaf (diff)
downloadaur-616413911d055a70e584aefc4aa95f4eae1c81a1.tar.gz
Add python-setuptools for Py 3.12 compat
Python chose to remove setuptools by default, leading to: Traceback (most recent call last): File "/build/thelounge-git/src/thelounge/_build/node_modules/node-gyp/gyp/gyp_main.py", line 42, in <module> import gyp # noqa: E402 ^^^^^^^^^^ File "/build/thelounge-git/src/thelounge/_build/node_modules/node-gyp/gyp/pylib/gyp/__init__.py", line 9, in <module> import gyp.input File "/build/thelounge-git/src/thelounge/_build/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 19, in <module> from distutils.version import StrictVersion ModuleNotFoundError: No module named 'distutils' gyp ERR! configure error gyp ERR! stack Error: `gyp` failed with exit code: 1 gyp ERR! stack at ChildProcess.onCpExit (/build/thelounge-git/src/thelounge/_build/node_modules/node-gyp/lib/configure.js:259:16) gyp ERR! stack at ChildProcess.emit (node:events:519:28) gyp ERR! stack at ChildProcess._handle.onexit (node:internal/child_process:294:12) gyp ERR! System Linux 6.8.9-arch1-2 gyp ERR! command "/usr/bin/node" "/build/thelounge-git/src/thelounge/_build/node_modules/sqlite3/node_modules/.bin/node-gyp" "rebuild" gyp ERR! cwd /build/thelounge-git/src/thelounge/_build/node_modules/sqlite3 gyp ERR! node -v v21.7.3 gyp ERR! node-gyp -v v8.4.1 gyp ERR! not ok
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4487bd1739d8..b31c38252f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=thelounge
pkgver=4.4.3
pkgsuffix="" #-rc.1
-pkgrel=1
+pkgrel=2
pkgdesc='Modern self-hosted web IRC client'
url='https://thelounge.chat/'
arch=('any')
license=('MIT')
depends=('nodejs')
options=('!lto')
-makedepends=('yarn' 'python' 'git')
+makedepends=('yarn' 'python' 'python-setuptools' 'git')
backup=('etc/thelounge/config.js')
source=(
"https://registry.npmjs.org/$pkgname/-/$pkgname-${pkgver}${pkgsuffix}.tgz"