summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDefunctLizard2021-04-17 23:10:00 -0600
committerDefunctLizard2021-04-17 23:10:00 -0600
commit44405a57fc02fa69e68671c20c9283aa11fd18a4 (patch)
tree546052a3be81cad4dd9aaff90ffd12c02f09bfd2 /PKGBUILD
downloadaur-44405a57fc02fa69e68671c20c9283aa11fd18a4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c873d3e5cfe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grant Handy <grantshandy AT gmail DOT com>
+
+_pkgname='thes'
+pkgname=${_pkgname}-git
+pkgver=0.1.2.r0.g2c88e93
+pkgrel=1
+pkgdesc="A CLI tool that finds the location of IP addresses."
+arch=('x86_64')
+url="https://github.com/DefunctLizard/thes"
+license=('APACHE-2.0')
+depends=('glibc')
+makedepends=('rust' 'git')
+source=("${_pkgname}::git+https://github.com/DefunctLizard/thes.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ # Binary
+ install -Dm755 target/release/$_pkgname $pkgdir/usr/bin/$_pkgname
+}