summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Tran2016-04-25 21:45:57 +1000
committerVictor Tran2016-04-25 21:45:57 +1000
commitd7f38ca7639fe512fe58e4865c72d2336c760408 (patch)
treec1c929cdfca16deeb29602a0d2a808700561b637 /PKGBUILD
downloadaur-d7f38ca7639fe512fe58e4865c72d2336c760408.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4c44a04d0bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theterminal
+pkgver=1.0
+pkgrel=0
+pkgdesc="Simple Terminal Emulator"
+arch=("x86_64")
+url="https://github.com/vicr123/theterminal"
+license=('GPL2')
+depends=('kwidgetsaddons' 'xdg-utils' 'qtermwidget')
+makedepends=('qtchooser' 'git' 'clang')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theterminal#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/theterminal" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/theterminal.desktop" "$pkgdir/usr/share/applications"
+}