summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-12-20 08:59:50 -0700
committerMark Wagie2021-12-20 08:59:50 -0700
commit27c2177622789c80b9fbd78961c54aa95e1098ae (patch)
tree48fbce5fa141d7b4870af5ed6303134fc20cd82a /PKGBUILD
parent016a242d53cd1268296aaf3e4533b62f6dec8171 (diff)
downloadaur-27c2177622789c80b9fbd78961c54aa95e1098ae.tar.gz
1.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 417b419d0696..3f018d9b38b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thingy
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Utility application used to make collections and quickly access recent and favorite documents."
arch=('any')
url="https://github.com/linuxmint/thingy"
license=('GPL3')
-depends=('python-gobject' 'python-setproctitle' 'xapp' 'xreader')
+depends=('python-gobject' 'python-setproctitle' 'xapp')
+optdepends=('libreoffice' 'xreader')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('6e8f1f4702c723dc93ff4e93804a65f85af62e0706794768f9214eaebf81be01')
+sha256sums=('a93fb65b52b71d8a84c486941b1ab04479ebbee0d4dc216384ea5c447997889e')
prepare() {
cd "$pkgname-$pkgver"
# Set version in About dialog
sed -i "s/__DEB_VERSION__/${pkgver//+*/}/g" "usr/lib/$pkgname/$pkgname.py"
+
+ # Fix license path
+ sed -i 's|common-licenses/GPL|licenses/common/GPL/license.txt|g' \
+ "usr/lib/$pkgname/$pkgname.py"
}
build() {