summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsmls2015-07-09 16:44:43 +0200
committersmls2015-07-09 16:44:43 +0200
commitbd8831c2c0925cb3c418362f2ec0c117beb6168b (patch)
tree4a940ed2e026c629ef0ae22636f70264f6bb7e55 /PKGBUILD
downloadaur-bd8831c2c0925cb3c418362f2ec0c117beb6168b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a61c375bc20e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=thomaswasalone-hib
+pkgver=0_20130429
+_hibver=1369349552
+pkgrel=2
+pkgdesc='Thomas Was Alone, a minimalistic puzzle-platformer (Humble Bundle version)'
+url='http://www.thomaswasalone.com/'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+if [ $CARCH == i686 ]; then
+ depends=('glu' 'libxcursor' 'alsa-lib' 'gcc-libs')
+ optdepends=('alsa-plugins: PulseAudio support')
+else
+ depends=('lib32-glu' 'lib32-libxcursor' 'lib32-alsa-lib' 'lib32-gcc-libs')
+ optdepends=('lib32-alsa-plugins: PulseAudio support'
+ 'lib32-libpulse: PulseAudio support')
+fi
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://thomaswasalone-linux-${_hibver}.tar"
+ 'thomaswasalone-hib.desktop')
+md5sums=('e7f8e766188718e16880b1137c430f35'
+ '8fe996d4b1a2b3ded634a9d487ea8893')
+
+package() {
+ cd $srcdir
+ _installdir="/opt/ThomasWasAlone"; _target="$pkgdir/$_installdir"
+
+ # Fix permissions
+ find "thomasLinuxStandalone" -type f -exec chmod 644 {} \;
+ find "thomasLinuxStandalone" -type d -exec chmod 755 {} \;
+ chmod 755 "thomasLinuxStandalone/thomasWasAlone"
+
+ # Install game files
+ mkdir -p $_target
+ cp -rT "thomasLinuxStandalone" "$_target"
+
+ # Install desktop entry
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # Install icon
+ install -Dm644 "$_target/thomasWasAlone_Data/Resources/UnityPlayer.png" \
+ "$pkgdir/usr/share/pixmaps/thomaswasalone.png"
+
+ # Install launcher script
+ echo -e "#!/bin/sh\ncd $_installdir && ./thomasWasAlone" > "launcher.sh"
+ install -Dm755 "launcher.sh" "$pkgdir/usr/bin/thomaswasalone"
+}