summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM.Reynolds2020-01-28 11:59:01 -0500
committerM.Reynolds2020-01-28 11:59:01 -0500
commit1b351f21324e559d372a04f6f18811e94bfc8728 (patch)
tree90bbfb7075bfc379cc772bb5e5c2feeb025eacb7 /PKGBUILD
parent6bb2da94dd39a19364817edd6b2aeae2a2f56ca7 (diff)
downloadaur-1b351f21324e559d372a04f6f18811e94bfc8728.tar.gz
Update 3.2.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3295858ca0a..d99724f82665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=thonny
-pkgver=3.2.4
+pkgver=3.2.6
pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('openssl' 'python' 'python-beautifulsoup4' 'python-docutils' 'mypy' 'python-asttokens'
'python-astroid' 'python-pylint' 'python-pyserial' 'python-jedi' 'tcl' 'tk')
source=("https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver-x86_64.tar.gz")
-sha256sums=('9532547adc49961826f65a29b3bbaab3bc325ef884efcdc94ff5f07b6ea2ad7c')
+sha256sums=('7dcf8de1e52c2f747a5ef0236475f17ceb8b59e4802395c8fbb9165272fa0a71')
package() {
@@ -21,6 +21,7 @@ package() {
# Update launch script for the correct Python version
sed -i 's|3.7|3.8|' "$pkgname/bin/thonny"
+ sed -i 's|3.7|3.8|' "$pkgname/templates/Thonny.desktop"
install -Dm 644 "$pkgname/templates/Thonny.desktop" "$pkgdir/usr/share/applications/thonny.desktop"
install -Dm 644 "$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -30,4 +31,4 @@ package() {
# Files must by copied manually for now in section below.
install -d 644 "$pkgdir/usr/lib/python3.8/site-packages/thonny"
cp -dr --no-preserve=ownership "$pkgname/lib/python3.7/site-packages/thonny" "$pkgdir/usr/lib/python3.8/site-packages"
-} \ No newline at end of file
+}